Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m confused but still hopeful

UploadFile not working / never triggers

This topic will have a lot of detailed information. Sorry for the long post, but it feels like I've tried almost everything with no success.

The tutorial I mainly followed is this:
But I've also tried some other examples from Blogs/Posts made by CodeOnTime staff.

I made a VERY simple example application so explaining the problem will be easier.
The project uses a database connection, that has been filled with the "HR Tutorial" database sample (Because it has the most basic things I would need) but I've also added a table for the Files data.
Here's a database diagram of it:

Simple enough, right?

Here's the "Files" controller:

I know that createForm1 is basically never used, but it's there anyways when I was testing :) The UploadFile function has some code in it (and a breakpoint, for when I run the project through Visual Studio's debug mode) but they never trigger/execute.
Also, there is no BLOB adapter at the moment, but when I added one using the File System method (with correct parameters and full access to the destination folder enabled for LITERALLY EVERY user/account so it can't be that it doesn't have permissions) and it still didn't work.

The controller "Jobs" has a DataView field of the "Files" controller:

So, running the application will show that the "Files" dataview is successfully in the "Jobs" editForm:

Clicking "Upload" opens the multiple file upload screen, where I just select multiple files (or just one) and click on "Submit". The window closes, and none of my breakpoints get triggered (When using Debug mode of course) nor does the code get executed:

(Tried with both those types of parameters and just `FilesModel instance`)

Has anyone here had a similar problem?
Does anyone here know a solution or possibly could point out what's wrong in what I'm doing?

Thanks in advance! <3
1 person has
this problem