Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m perplexed

Email not being Sent by business rule

Having an issue sending a notification email when a status is changed on an inquiry.

I know that that system is triggering the business rule that is to trigger the sending of the email because I have a message that is displayed when the snippet of code is run by the system.

I know that the azure server is not even attempting to connect to the SMTP server as I do not see any connection attempts in the log files on the SMTP server.

Below is the code that should be triggering the send of of the email

Type: SQL
Command: Update
Phase: After
Name: IsProject_TriggerEmail

set @BusinessRules_Whitelist = 'Nothing'
if @IsProject_Modified = 1 AND @IsProject_Newvalue = 1
BEGIN
set @BusinessRules_Whitelist = 'IsProject_NotifyEmail'
set @Result_ShowMessage = 'Sending Email'
set @Result_Continue = 1
END



Here is the code for the business rule email.
Type: Email
Command: Update
Phase: After
Name: IsProject_NotifyEmail


Host: terracana.ca
Port: 465
EnableSSL: true
UserName: ***(Hidden)***@terracana.ca
Password: ***(Removed)***

From: ***(Hidden)***@terracana.ca
To: ***(Hidden)***@terracana.ca
Subject: {InquiryCompleteNumber} has been updated to a Project {ProjectCompleteNumber}

Hello

This email is to inform you that {InquiryNumbAddDesc} has been updated to Project: {ProjectNumbAddDesc}

Thank You
TerraCana Operations System


I have tried setting the SMTP setting in the application setting.
I have also tried setting the SMTP network setting to defaultCredentials to True and False at different times but this then generates an error "Unrecognized Attribute 'defaultCredentials'... "

I have based my setup off the thread located at http://community.codeontime.com/codeo...

I know the SMTP requires authentication of "User@domain.com" with the password.
I have also Tried SSL Enabled and Disabled and set the corresponding ports accordingly for the SMTP Server

Could have I missed a setting with Azure to allow it to make outbound SMTP connections?

Brent
1 person has
this question
+1
Reply