I’m confident

COT Not Publishing, Not Uploading Files to Azure

Okay I ran into an issue this morning when I was trying to publish my application to my Staging and Production. I ended up going through a whole process in trouble shooting issue including resetting my Azure Publishing Config in COT

Then I looked at the log output for COT to found that a Folder on my local system was causing the problem

3/5/2019 1:40:32 AM execute fileName="C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_compiler.exe" arguments="-nologo -f -v / -p "\app" "[Documents]\Code OnTime\Publish\Web Site Factory\TerraCanaOperatoins\_server"" mode="wait"
3/5/2019 1:40:34 AM error ASPRUNTIME: The target directory could not be deleted. Please delete it manually, or choose a different target.

For some reason COT was unable to Delete the folder "_server"
So I navigated to the folder and renamed the_server to _server_000 and then re ran the publish function with COT and everything worked with out any errors.

I hope this helps
1 person has
this problem