I’m disappointed

COT 8.5.11 (converted from 8.5.7) Forms initially hang and display Loading...

I converted my 8.5.7 project to 8.5.11 by opening the project and then selecting Browse (which launched the conversion process). The converted project opened no problem and displayed forms and data without any performance problems.
Then I noticed that the new 8.5.11 grid functionality (eg Extending column widths etc) was not working. So I went into Design mode in my newly converted project and clicked on Browse which launched a full compile.
OK, the 8.5.11 new grid functionality appeared.
However, now I am getting a performance issue - a 'Loading...' message consistently appears when I open some of my forms.
Has anyone else experienced this problem?
1 person has
this question
+1
Reply
  • Joanne,

    Can you see the same issue in the demo site at http://demo.codeontime.com? Can you attach a screenshot of the loading message?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Joanne:

    I have recently started my (painful) transition from CoT 8.5.9 to 8.5.11. And from the beginning many "bugs" appeared. Please consider that everything was working fine in 8.5.9

    1.- Some grids simply stopped rendering data.

    After turning on Microsoft Edge's Developer Tools I discovered some legacy view styles that used variables that no longer existed. For some reason, previous versions were lenient with this type of errors, but not anymore. Deleting the offending styles fixed the problem. This is one of CoT's best advices, when a mysterious error happens, it is usually broken javascript.

    By the way, this same issue caused some lookups to hang.

    2.- Date inputs in confirmation modal forms broke.

    For some strange reason, perfectly working confirmation modal forms containing dates ceased to work properly, sending a "Date is Expected" error in the first click and all parameter values disappearing to the caller in the second click. I discovered that the problem was in the modal form controller's actions. Using a Custom When New action and a Confirm when Custom action for data validation. It seems that now, every action has an implicit causesValidation attribute value of "true". Having both the Custom and the Confirm actions with this causesValidation now has the effect of validating the form twice. This double validation corrupts the date format and destroys the parameter value list. Unchecking "Causes Validation" for all Confirm actions solved the problem. But watch out, if you uncheck "Causes Validation", save, and then save again, "Causes Validation" now is true again with out explicit action of the user, so be careful when editing actions where the desired "Causes Validation" attribute is expected to be "false".

    3.- Project Designer intermittently crashes.

    This is really frustrating, because after some crashes the web site will get corrupted. Deleting all files while preserving the project's main repositories, and refreshing, generating and copying back all custom code fixed the problem. No crashes since.

    These are all my discoveries to date. I hope this helps.

    Best regards,

    Roberto
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated