Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Adding Update/Email After Breaks Application

I have an application that send an email on insert when created a record...
Insert - SQL - After

if @ForemanEsignID is not null and @ForemanEdate is not null
BEGIN
set @BusinessRules_Whitelist = 'DistrictMgrEmail'
set @Result_ShowMessage = 'Sending Email'
set @Result_Continue = 1
set @BusinessRules_Whitelist = 'Nothing'
END

Insert - Email - After (name: DistrictMgrEmail)

Host: hidden
Port: 25
UserName: administrator
Password: hidden
EnableSSL: false

From: {ForemanEsignSupervisorEmail}
To: "Brandy Riggs" <briggs@hidden.com>
Cc: "Brandy Riggs" <briggs@hidden.com>
Subject: Personnel Requistion Approval Requested

<html>
<body>

Please approve the personnel requisition in the link below <br /> <br />

<a href='http://wacoapps/netapps/personnelreq/pages/personnel-req-field?_controller=PersonnelReqField&ReqID={ReqID}&_commandName=Edit&_commandArgument=editForm1'>{JobTitle}</a>

<br /><br />

Sincerely, <br />
{Supervisor}

</body>
</html>

This insert works perfectly everytime...

So the Supervisor gets this email, and should be able to click on the link insert their name(approving the req) and it should be sent on to the next supervisor...
So I set up the following:
Update - SQL - After

If @DistrictMgrEsignID is not null and @DivisionMgrEsignID is null
BEGIN
set @BusinessRules_Whitelist = 'DivisionMgrEmail'
set @Result_ShowMessage = 'Sending Email'
set @Result_Continue = 1
set @BusinessRules_Whitelist = 'Nothing'
END
else
If @DivisionMgrEsignID is not null and @VpesignID is null
BEGIN
set @BusinessRules_Whitelist = 'DivisionVPEmail'
set @Result_ShowMessage = 'Sending Email'
set @Result_Continue = 1
set @BusinessRules_Whitelist = 'Nothing'
END
else
If @VpesignID is not null and @HresignID is null
BEGIN
set @BusinessRules_Whitelist = 'HRMgrEmail'
set @Result_ShowMessage = 'Sending Email'
set @Result_Continue = 1
set @BusinessRules_Whitelist = 'Nothing'
END
else
if @HresignID is not null
BEGIN
set @BusinessRules_Whitelist = 'Nothing'
END



Update - Email - After (name: DivisionMgrEmail)

Host: hidden
Port: 25
UserName: administrator
Password: hidden
EnableSSL: false

From: "Brandy Riggs" <briggs@hidden.com>(changed this for testing)
To: briggs@hidden.com
Subject: Personnel Requistion Approval Requested

<html>
<body>

Please approve the personnel requisition in the link below <br /> <br />

<a href='http://wacoapps/netapps/personnelreq/pages/personnel-req-field?_controller=PersonnelReqField&ReqID={ReqID}&_commandName=Select&_commandArgument=editForm1'>{JobTitle}</a>

<br /><br />

Sincerely, <br />
{DistrictMgrSupervisor}

</body>
</html>


Once i add the update, everytime i click on the record I get the attached error



does anyone know why this is happening?

I have done the following
Copied in older Application.Log.xml
Deleted the Application.Log.xML and regenerated
Deleted and re-added the Library
1 person has
this problem
+1
Reply